Quelle version de Delphi utilisez-vous
Principalement en 2012 ? Et quelle édition ?

Le , par Rayek

0PARTAGES

1  0 
Quelle version de Delphi utilisez vous ?
Lien vers l'ancienne discussion

Quelle version de Delphi utilisez vous principalement ? Si vous utilisez plusieurs versions alors votez pour celle que vous utilisez le plus. Si vous prévoyez de changer de version prochainement vous pouvez l'indiquer en réponse à ce topic ou voter directement pour le nouvelle version que vous allez utiliser.

Vous pouvez également preciser quelle édition (perso, pro, entreprise, architecte) vous utilisez.

Le sondage précédent vient d'être effacé car nombre d'entre vous ont sans doute changé de version de Delphi ou prévoient de le faire prochainement.

Le 1/1/2005 le résultat du précédent sondage était le suivant :
Code : Sélectionner tout
1
2
3
4
5
6
7
8
9
Delphi 7          47%  [ 287 ] 
Delphi for .NET    0%  [   4 ] 
Delphi 6          32%  [ 196 ] 
Delphi 5          13%  [  83 ] 
Delphi 4           2%  [  16 ] 
Delphi 3           1%  [   9 ] 
Delphi 2           0%  [   1 ] 
Delphi 1           0%  [   3 ] 
Total des votes : 599
Le 11/03/2006 le résultat du précédent sondage était le suivant :
Code : Sélectionner tout
1
2
3
4
5
6
7
8
9
10
Delphi 2005       20%  [  76 ] 
Delphi 8           1%  [   5 ] 
Delphi 7          48%  [ 179 ] 
Delphi 6          19%  [  73 ] 
Delphi 5           6%  [  23 ] 
Delphi 4           1%  [   7 ] 
Delphi 3           1%  [   5 ] 
Delphi 2           0%  [   2 ] 
Delphi 1           0%  [   2 ] 
Total des votes : 372
Le 15/06/2009 le résultat du précédent sondage était le suivant :
Code : Sélectionner tout
1
2
3
4
5
6
7
8
9
10
11
Delphi 2006       11%  [  71 ] 
Delphi 2005       16%  [  98 ] 
Delphi 8           0%  [   2 ] 
Delphi 7          42%  [ 268 ] 
Delphi 6          16%  [  99 ] 
Delphi 5           9%  [  59 ] 
Delphi 4           2%  [  13 ] 
Delphi 3           1%  [   7 ] 
Delphi 2           0%  [   4 ] 
Delphi 1           0%  [   5 ] 
Total des votes : 626
Le 03/07/2012 Le resultat du précédent sondage était le suivant
Code : Sélectionner tout
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
Delphi 2009 		16 	21,33%
Delphi Prism 		2 	2,67%
Delphi 2007 		12 	16,00%
Turbo Delphi 		2 	2,67%
Delphi 2006 		6 	8,00%
Delphi 2005 		4 	5,33%
Delphi 8 		0 	0%
Delphi 7 		37 	49,33%
Delphi 6 		10 	13,33%
Delphi 5 		5 	6,67%
Delphi 4 		4 	5,33%
Delphi 3 		1 	1,33%
Delphi 2 		1 	1,33%
Delphi 1 		0 	0%
Total des votes : 100

Une erreur dans cette actualité ? Signalez-le nous !

Avatar de Simicro
Membre habitué https://www.developpez.com
Le 18/08/2014 à 9:37
Bonjour à tous,

A l'équipe du forum : sauf erreur de ma part, je n'ai pas vu de sondage pour 2013 / 2014.

Serait-il possible de créer une nouvelle version de ce sondage afin d'avoir une image actualisée des versions de Delphi utilisée par le public ?
1  0 
Avatar de ouiouioui
Membre expérimenté https://www.developpez.com
Le 03/07/2012 à 17:34
le sondage étant à choix multiple il aurait fallu rajouter (perso, pro, entreprise, architecte) dedans, dommage qu'on puisse pas éditer son choix non plus
0  0 
Avatar de Rayek
Modérateur https://www.developpez.com
Le 03/07/2012 à 17:40
Citation Envoyé par Rayek Voir le message

Quelle version de Delphi utilisez vous principalement ? Si vous utilisez plusieurs versions alors votez pour celle que vous utilisez le plus. Si vous prévoyez de changer de version prochainement vous pouvez l'indiquer en réponse à ce topic ou voter directement pour le nouvelle version que vous allez utiliser.

Vous pouvez également preciser quelle édition (perso, pro, entreprise, architecte) vous utilisez.
J'ai repris l'existant et je n'ai rajouté que les nouvelles versions de delphi.

Pour l'édition c'est le forum qui ne le permet pas.
0  0 
Avatar de Simicro
Membre habitué https://www.developpez.com
Le 03/07/2012 à 19:14
Merci Rayek d'avoir créé ce nouveau sondage, avec les dernières versions de Delphi.

J'utilise Delphi XE2 Starter.

J'ai voté dans "Delphi Starter".
0  0 
Avatar de Okaryn
Membre confirmé https://www.developpez.com
Le 03/07/2012 à 19:38
Voté Delphi XE2

Est-ce qu'avec les dernières versions XE et XE2, D7 va être détrôné de sa place de leader depuis des années ? Suspens...
0  0 
Avatar de skywaukers
Membre chevronné https://www.developpez.com
Le 03/07/2012 à 21:01
Pour ma part, c'est D7 (encore) et XE2. Et j'avoue que XE2 me plait vraiment beaucoup, je pense, j'espère qu'il va détroner Delphi 7 qui commence à vieillir. Il avait tellement de qualités. Mais Delphi XE2 a des atouts, dans ses avancées au niveau du langages (les génériques pas exemple), son ouverture vers les autres plate-formes.
En révant un petit peu on aimerait bien qu'il arrive à revenir sur le devant de la scène

Son seul problème reste encore le web. Intraweb c'est bien, mais ça reste encore un outils tiers, intégré mais limité si on ne remet pas la main à la poche, et puis ce serait mieux si cela était vraiment pris en charge par Embarcadero, avec la qualité qu'on leur connait.

@++
Dany
0  0 
Avatar de ShaiLeTroll
Expert éminent sénior https://www.developpez.com
Le 04/07/2012 à 10:28
Je migre en ce moment même de 2007 à XE2, mais en C++Builder Entreprise ...

J'ai utilisé D3 à D7 entre 1999 et 2010, et pas forcément dans un ordre croissant
D7 à lui seul représentent 90% de mon utilisation entre 2004 et 2010
D7 reste la GROSSE version !

XE2 et ses suivantes ont la possibilité de la dépassé surtout si FMX prend la main !

Nos commerciaux réclament une version Web ... avec un peu de chance, on choisira plutôt une version C++Builder XE4 avec FMX Win32\64\MAC\Linux et terminaux mobiles avec connexion au Server DataSnap VCL
0  0 
Avatar de SergioMaster
Rédacteur/Modérateur https://www.developpez.com
Le 04/07/2012 à 14:51
Citation Envoyé par ShaiLeTroll Voir le message

Nos commerciaux réclament une version Web ... avec un peu de chance, on choisira plutôt une version C++Builder XE4 avec FMX Win32\64\MAC\Linux et terminaux mobiles avec connexion au Server DataSnap VCL
je vois que comme moi tu es un optimiste

maintenance existant D3,D7 ,nouveaux dev D2010 , XE2 en test

et au vu des résultats je sens que je vais être bien seul à rester D3 pour ma maintenance
0  0 
Avatar de ShaiLeTroll
Expert éminent sénior https://www.developpez.com
Le 04/07/2012 à 16:37


Pour tes nouveaux Dev, pourquoi ne pas utiliser XE2 ?
Les tests ça va un temps, mais un jour faut se lancer (je suis le dernier à migrer, mes collègues doivent avoir passer le cap 2007->XE2 depuis presque 4 mois déjà)

Entre 2010 et XE2, il y a effectivement FMX mais XE2 est plus stable en ce qui concerne l'UNICODE (surtout côté C++Builder)

D7 et D3, j'ai vécu ça, il fallait que je développe en D7 mes modules pour la version N du framework mais comme 90% des clients étaient encore en version N-2, je me tapais la reprise en D3 (je jouais avec les directives)
On n'était pas nombreux à le faire, pas bol, je suis tombé sur un module devant fonctionner sous N-2 mais au moins cela m'évitait DevExpress qui était devenu le standard IHM pour D7 mais qui n'était pas utilisé en D3
0  0 
Avatar de SergioMaster
Rédacteur/Modérateur https://www.developpez.com
Le 05/07/2012 à 12:06
Citation Envoyé par ShaiLeTroll Voir le message

Pour tes nouveaux Dev, pourquoi ne pas utiliser XE2 ?
Parce que j'attends
- la compilation LINUX avec impatience et que la XE3 est prévue courant septembre

-mais aussi parce que même si Firemonkey semble super il est bien jeune pour des applications de gestion
( DBGrids sans multiselect, sans indicateur ....
Pas de Docking , quoique j'ai réussi a détourner ça,
Pas encore de reporting sauf si l'on considère l'annonce de Fastreport)

- Je n'ai pas de Mac et que le monde Mac n'est pas dans les projets de l'entreprise contrairement peut être a Androïd (quand on voit ce que coute un dev et déploiement pour ios )
0  0 
Responsables bénévoles de la rubrique Pascal : Gilles Vasseur - Alcatîz -

Partenaire : Hébergement Web