Sortie de la version 1.0.14 de Lazarus
Il s'agit d'une version corrective toujours basée sur le compilateur Free Pascal 2.6.2

Le , par Ph. B., Expert confirmé
Sortie de la version 1.0.14 de Lazarus
Il s'agit d'une version corrective



Bonjour à tous,

L'équipe en charge du développement de Lazarus continue de faire évoluer l'EDI et vient de faire passer la prochaine version 1.2.x sous statut "Release Candidate". Elle n'oublie cependant pas la version actuelle pour laquelle elle a produit plusieurs corrections.

La version 1.0.14 est donc disponible en téléchargement ICI suivant le communiqué officiel en date du 19 novembre.

Lazarus 1.0.14 utilise le même compilateur que les versions précédentes 1.0.8 à 1.0.12, à savoir FPC 2.6.2.

La liste des corrections et améliorations peut être consultée ICI pour FPC et ICI pour Lazarus.

Pour rappel, Lazarus peut fonctionner avec différents systèmes d'exploitation :
  • Windows : 98, 2000, XP, Vista, 7, 32 ou 64 bits,
  • FreeBSD/Linux : gtk 2.8 ou qt4.5, 32 ou 64 bits,
  • Mac OS X : 10.5, LCL seulement 32 bits, les applications n'utilisant pas la LCL peuvent être 64 bits.

Ceux qui récupèrent les sources de l'EDI peuvent le faire depuis le dépôt SVN en utilisant le tag : http://svn.freepascal.org/svn/lazaru...lazarus_1_0_14

Pour ceux d'entre vous qui seraient bloqués par SourceForge, cette version est accessible sur les sites miroirs suivants :
ftp://freepascal.dfmk.hu/pub/lazarus/releases/
puis après synchronisation :
http://michael-ep3.physik.uni-halle....arus/releases/
et :
http://mirrors.iwi.me/lazarus/

Qu'en pensez-vous ?


Vous avez aimé cette actualité ? Alors partagez-la avec vos amis en cliquant sur les boutons ci-dessous :


 Poster une réponse

Avatar de Jon Shannow Jon Shannow - Membre expert https://www.developpez.com
le 27/11/2013 à 9:43
En marge de Lazarus, quelqu'un sait-il si l'utilisation de SQLite en 64 bits a été revue ? Personnellement, j'ai abandonné SQLite et Lazarus 64 bit, car les DLLs SQLite ne sont pas compatibles et je n'en ai pas trouvé de fonctionnelles.

Donc, je suis resté en Lazarus 32bits sous Seven 64 !

Merci JS
Avatar de Ph. B. Ph. B. - Expert confirmé https://www.developpez.com
le 27/11/2013 à 17:14
Bonjours
Citation Envoyé par Jon Shannow  Voir le message
En marge de Lazarus, quelqu'un sait-il si l'utilisation de SQLite en 64 bits a été revue ? Personnellement, j'ai abandonné SQLite et Lazarus 64 bit, car les DLLs SQLite ne sont pas compatibles et je n'en ai pas trouvé de fonctionnelles.

SqLite ne fournit effectivement pas de dll 64bits pré-compilée.

D'où AMHA, 3 contournements possibles :
  1. Lazarus 32 bits et la dll officielle : une application 32 bits pouvant aussi fonctionner avec un SE 64 bits ,
  2. Utiliser un compilateur C 64 bits et construire la dll,
  3. Utiliser la dll 64 bits pré-compilée fournie par Synopse, comme l'indique Arnaud Bouchez sur son blog. Ils l'utilisent régulièrement avec leur framework mORMot. Ce n'est toutefois pas la toute dernière version sortie (3.7.16 contre 3.8.1)
Avatar de Jon Shannow Jon Shannow - Membre expert https://www.developpez.com
le 28/11/2013 à 8:29
Ok, merci de la réponse, je n'ai pas réussi à faire fonctionner mon appli avec la solution de Synopse, alors je continue en Lazarus 32bit qui, effectivement fonctionne très bien sous un SE 64 bits.
Avatar de Jipété Jipété - Expert éminent https://www.developpez.com
le 28/11/2013 à 23:04
Bonsoir,
Citation Envoyé par Ph. B.  Voir le message
(...) La version 1.0.14 est donc disponible en téléchargement ICI suivant le communiqué officiel en date du 19 novembre.

Une question toute bête : on est à chaque fois obligé de tout télécharger puis tout effacer de la précédente version et enfin tout réinstaller de la nouvelle ?

Y a pas un truc qui ferait juste un "diff" entre ce qui est actuellement présent et ce qu'il faut mettre à jour ?

Parce que je peux supposer, vu la date de certains exemples, qu'il y a pas mal de choses dans les tréfonds de l'arborescence qui ne bougent pas.

Et à côté de ça, si on installe des trucs sympas ou perso, et qu'il faut à chaque fois sauvegarder tout ça dans un coin pour le réinstaller ensuite, je trouve ça passablement, euh, comment dire, gonflant et lourdingue (résultat je suis toujours en 1.0.10...)
Avatar de SoftChris SoftChris - Membre régulier https://www.developpez.com
le 29/11/2013 à 9:20
Moi perso je désinstalle, je réinstalle et je réintègre les paquets persos et autres, tout çà en une dizaine de minutes. C'est pas long, c'est gratuit et c'est beaucoup plus simple que sur Delphi.... Vive Lazarus et merci merci merci à la communauté pour cette nouvelle version !!
Avatar de Ph. B. Ph. B. - Expert confirmé https://www.developpez.com
le 29/11/2013 à 15:52
Citation Envoyé par Jon Shannow  Voir le message
... je n'ai pas réussi à faire fonctionner mon appli avec la solution de Synopse...

Peut-on avoir plus de détails ?
Erreur(s) lors de la compilation ?
Erreur(s) lors de l'exécution, fonctionnement erratique ?
Avatar de Jon Shannow Jon Shannow - Membre expert https://www.developpez.com
le 29/11/2013 à 16:07
Citation Envoyé par Ph. B.  Voir le message
Peut-on avoir plus de détails ?

Plantage à la la connexion de la base. Mais, c'est pas grave. Ça marche en 32bits. Et j'attendrais que les DLL officielles soient compilées en 64 bits, ça finira bien par arriver, à moins que le projet ne soit mort ?
Avatar de Ph. B. Ph. B. - Expert confirmé https://www.developpez.com
le 29/11/2013 à 16:16
Citation Envoyé par Jipété  Voir le message
Une question toute bête : on est à chaque fois obligé de tout télécharger puis tout effacer de la précédente version et enfin tout réinstaller de la nouvelle ?

J'utilise la même approche que SoftChris, et je redoute (peut-être à tort) les conséquences d'une mise à jour différentielle...
Les paquets, les sources annexes et les paramètres sont dans une arborescence qui est conservée lors d'une mise à jour. Une fois l'installation terminée, je démarre Lazarus et reconstruit l'IDE. C'est simple, relativement rapide (surtout comparé à une mise à jour Delphi XEx ), et toujours effectué à un moment où je peux me consacrer à autre chose...
Enfin j'effectue ces opérations sous 2 Windows et 1 Linux...
Avatar de Jiji66 Jiji66 - Membre averti https://www.developpez.com
le 08/12/2013 à 19:26
Très comptent de cette nouvelle version qui marche super bien en environnement 32bits Windows.
Y-a-t-il Des indices pour une version pré-compilée sur Raspberry Pi ?
Avatar de Pmc21 Pmc21 - Futur Membre du Club https://www.developpez.com
le 14/12/2013 à 22:17
Je ne pense pas que ce soit ça que tu cherches, mais bon... Je te donne le lien quand même:
https://pypi.python.org/pypi/raspi.lpd8806/0.2
Responsables bénévoles de la rubrique Pascal : Gilles Vasseur - Alcatîz -