Vous êtes nouveau sur Developpez.com ? Créez votre compte ou connectez-vous afin de pouvoir participer !

Vous devez avoir un compte Developpez.com et être connecté pour pouvoir participer aux discussions.

Vous n'avez pas encore de compte Developpez.com ? Créez-en un en quelques instants, c'est entièrement gratuit !

Si vous disposez déjà d'un compte et qu'il est bien activé, connectez-vous à l'aide du formulaire ci-dessous.

Identifiez-vous
Identifiant
Mot de passe
Mot de passe oublié ?
Créer un compte

L'inscription est gratuite et ne vous prendra que quelques instants !

Je m'inscris !

Sortie de la version 1.2.4 de l'IDE Lazarus
Une version corrective qui s'appuie sur la dernière version de Free Pascal 2.6.4

Le , par Ph. B.

20PARTAGES

1  0 
Sortie de la version 1.2.4 de Lazarus
Il s'agit d'une version corrective qui s'appuie sur la dernière version de FreePascal 2.6.4



Bonjour à tous,

L'équipe en charge du développement de Lazarus vient de publier une nouvelle version de l'EDI selon le
communiqué officiel en date du 16 juin.

La version 1.2.4 est disponible au téléchargement ICI.

Cette version ainsi que la 1.2.2 s'appuie sur la version 2.6.4 du compilateur alors que les versions précédentes 1.0.x à 1.2.0, utilisaient la 2.6.2.

La liste des changements peut être consultée ICI.

Pour rappel, Lazarus peut fonctionner avec différents systèmes d'exploitation, les prérequis minimaux sont :
  • Windows : 98.
    Sous Windows, l'installeur autorise 2 installations indépendantes. Plus de détails ICI
    Sous Windows 64 bits, il est toutefois préconisé d'utiliser la version 32 bits (avec compilateur croisé 32/64 bits pour ceux pour qui le 64 bits est indispensable). Plus de détails ICI.
  • FreeBSD/Linux : gtk 2.8 ou qt4.5, 32 ou 64 bits.
  • Mac OS X : 10.5 pour les stations à base de processeur Intel, 10.4 pour celles à base de PowerPc ; LCL seulement 32 bits, les applications n'utilisant pas la LCL peuvent être 64 bits.

Ceux qui récupèrent les sources de l'EDI peuvent le faire depuis le dépôt SVN en utilisant le tag : http://svn.freepascal.org/svn/lazaru.../lazarus_1_2_4

Pour ceux d'entre vous qui seraient bloqués par SourceForge, cette version est accessible sur les sites miroirs suivants :
ftp://freepascal.dfmk.hu/pub/lazarus/releases/
puis après synchronisation :
http://michael-ep3.physik.uni-halle....arus/releases/
et :
http://mirrors.iwi.me/lazarus/

Qu'en pensez-vous ?

Une erreur dans cette actualité ? Signalez-le nous !

Avatar de Jon Shannow
Membre extrêmement actif https://www.developpez.com
Le 19/06/2014 à 11:47
Citation Envoyé par Ph. B. Voir le message

Qu'en pensez-vous ?
Que je ne peux plus recompiler avec le nouveau freepascal !
0  0 
Avatar de Ph. B.
Expert confirmé https://www.developpez.com
Le 20/06/2014 à 0:48
Citation Envoyé par Jon Shannow Voir le message
Que je ne peux plus recompiler avec le nouveau freepascal !
S'il s'agit de Zeos, la réponse a déjà été donnée, la version 7.13a est compilable sous la 1.2.4...
0  0 
Avatar de Jon Shannow
Membre extrêmement actif https://www.developpez.com
Le 20/06/2014 à 8:54
Citation Envoyé par Ph. B. Voir le message
S'il s'agit de Zeos, la réponse a déjà été donnée, la version 7.13a est compilable sous la 1.2.4...
Sauf que ça ne fonctionne pas avec mes bases SQLite, j'ai plein d'erreurs à l'exécution, et au final, pour l'instant, je reste sur la version qui fonctionne chez moi !
0  0 
Avatar de ovni76
Membre actif https://www.developpez.com
Le 08/07/2014 à 10:54
Bobjour,
J'ai installé la vesrion de lazarus 1.2.4 sur windows xp 32b, fedora 20 32b et fedora 20 64b sans problème, mais pour sqlite j'utilise les composants natifs.
A+
0  0